Delay in receiving Whatsapp (Twilio) messages

Incident Report for Orlo

Resolved

Delivery latency is back to normal.
Posted Jun 30, 2025 - 21:46 UTC

Identified

There is currently a delay on incoming Twilio (WhatsApp) messages to Orlo.

Twilio have acknowledged the problem, and it's on their status page.

Further details are available here - https://status.twilio.com/incidents/9pn51bwxq9hk

We'll continue to monitor the problem.
Posted Jun 30, 2025 - 18:27 UTC
This incident affected: Social Networks.